縱橫輸入法簡介

縱橫輸入法（簡稱縱橫碼）是一種簡單易學和實用的漢字輸入方法，目前已在江蘇省、浙江省、廣東省、河南省、安徽省、貴州省、廣西省、上海市、北京市、香港特區和西藏自治區等地得到廣泛推廣應用。利用縱橫輸入法，廣大電腦用戶可以方便地輸入漢字資訊。在上海市，經上海市電腦考核辦公室組織的專家評審，確認縱橫輸入法爲上海市市民電腦等級考試可選用的一種漢字輸入法；在江蘇省，經江蘇省電腦考核辦公室組織的專家評審，同意縱橫輸入法在電腦基礎技術考核中使用；在北京市，北京市教育委員會於2004年6月下發了《北京市教育委員會關於舉辦電腦縱橫漢字輸入法達標證書培訓及考試的通知》（京教職成[2004]9號），文件明確規定“考試合格者由市教委和北京考試院聯合頒發全市統一印製的電腦縱橫漢字輸入法等級證書”。

蘇州大學縱橫漢字資訊技術研究所自一九九三年成立以來，一直致力於研究開發縱橫輸入系統及相關軟體。 一九九六年三月，縱橫輸入系統獲得江蘇省優秀軟體二等獎，同年十二月獲得江蘇省教委科技進步一等獎。一九九八年十二月，“縱橫Windows套件”通過了江蘇省科學技術委員會的技術鑒定。

縱橫輸入法可以在移動電話下安裝使用。

縱橫輸入法的特點是簡單易學、簡繁通用、詞組豐富、功能強大。

縱橫輸入法發揮了縱橫碼自身的優點，科學地選定了功能鍵的位置。

縱橫輸入法規定單字的輸入碼最多爲四碼，詞組的輸入碼最多爲六碼。

縱橫輸入法還提供尾碼容錯功能，單字或詞組輸入時，如尾碼不正確，而有關編碼並無對應單字或詞組時，系統會提供最接近之編碼的單字或詞組，以供選擇。


縱橫漢字輸入法簡易版是簡化的縱橫漢字輸入系統

關於縱橫輸入法

作業系統：移動電話 Windows Mobile 版

縱橫碼由香港周忠繼先生發明。

縱橫漢字輸入法系列軟體由蘇州大學縱橫漢字資訊技術研究所與蘇州豐利資訊技術有限公司合作研製開發。

歡迎使用者提出寶貴意見。

中國香港：

聯　　絡：豐利科技有限公司

電　　話：852-27311701

傳　　真：852-27396427

通訊地址：九龍尖沙咀東部加連威老道98號東海商業中心2樓

電子郵箱： ckcsys@netvigator.com

網　　站： http://www.ckcsys.com.hk/

中國大陸：

聯　　絡：縱橫漢字信息技術研究所

電　　話：86-512-67165762

傳　　真：86-512-67451516

郵　　編：215006

通訊地址：蘇州大學158信箱

電子郵箱：ckc@zhhz.org

網　　站： http://www.zhhz.org/


安裝縱橫輸入法

在移動電話上安裝輸入法需要4個文件，分別是ZhSetup.exe、Data_1.cab、Data_2.cab、Data_3.cab，其中，ZhSetup.exe是繁體輸入法安裝程式，運行該程式即可在移動電話上安裝縱橫輸入法。

安裝步驟:

步驟1、首先，確定移動電話與PC機的連接（連接方式有紅外，藍牙，資料線等，可任選一種），然後運行ZhSetup.exe程式，PC機上會顯示出如圖1的安裝向導，按「下一步（N）」進行安裝。

圖1. 安裝步驟1

步驟2、安裝向導確認PC機與移動電話連接成功，如下圖2所示，此時可按「下一步（N）」繼續安裝。如無法確認連接，請檢查移動電話與PC機連接是否正常。

圖2. 安裝步驟2：確認PC機與移動電話連接

步驟3、安裝程式自動檢測移動電話內的可安裝的存儲空間，並提供修改存儲位置，如下圖3所示。如無需進行修改，可按「下一步（N）」可直接到步驟5進行安裝。

圖3. 安裝步驟3：檢測存儲空間及安裝路徑情況

步驟4、如需要進行修改程式安裝路徑，可按上圖3中的修改按鈕，出現對話方塊，如下圖4所示，可根據需要進行修改程式檔夾名稱或安裝檔夾位置，按「下一步（N）」到步驟5進行安裝。

圖4. 安裝步驟4：修改程式安裝路徑

步驟5、程式開始執行安裝，如下圖5所示。

圖5. 安裝步驟5：安裝程式

步驟6、程式安裝完成，按「完成」結束安裝，如下圖6所示。

注：縱橫輸入法安裝完成後，建議重新啓動移動電話，以便輸入法可以正常使用。

圖6. 安裝步驟6：安裝完成


刪除縱橫輸入法

在移動電話上刪除縱橫輸入法需要使用ZhSetup.exe繁體輸入法安裝程式，運行該程式即可在移動電話上刪除縱橫輸入法。

刪除步驟:

步驟1、首先，確定移動電話與PC機的連接（連接方式有紅外，藍牙，資料線等，可任選一種），然後運行ZhSetup.exe程式，PC機上會顯示出如圖1的安裝向導，按「下一步（N）」到步驟2。

圖1. 刪除步驟1

步驟2、安裝向導確認PC機與移動電話連接成功，如下圖2所示，此時可按「下一步（N）」到步驟3。如無法確認連接，請檢查移動電話與PC機連接是否正常。

圖2. 刪除步驟2：確認PC機與移動電話連接

步驟3、出現修改、修復或刪除程式頁面，可根據需要選擇，如下圖3所示。選擇後，按「下一步（N）」到步驟4，完成維護。

圖3. 刪除步驟3：修改、修復或刪除程式頁面

步驟4、程式維護完成，按「完成」結束，如下圖4所示。

注：縱橫輸入法維護完成後，建議重新啓動移動電話，以便輸入法可以正常使用。

圖4. 安裝步驟4：安裝完成


輸入方式的切換

在移動電話上可使用「*」鍵切換縱橫輸入法、英文以及數位輸入，如下圖1所示。

圖1 輸入法切換鍵

長按「*」鍵約2秒，當螢幕上方出現「CKC」圖示時，即可使用縱橫輸入法輸入漢字，如下圖2所示。

圖2 縱橫輸入法狀態

長按「*」鍵約2秒，當螢幕上方出現「abc」圖示時，即可直接輸入英文，如下圖3所示。此時再短按一下「*」鍵，可切換英文大小寫；短按兩下「*」鍵，可永久切換至英文大寫狀態。

圖3 英文輸入狀態

長按「*」鍵約2秒，當螢幕上方出現「123」圖示時，即可直接輸入數位，如下圖4所示。

圖4 數位輸入狀態


縱橫輸入法功能鍵

在縱橫輸入法輸入方式下，用戶可完全利用縱橫輸入法在移動電話中進行漢字輸入。縱橫輸入法的輸入鍵、功能鍵在移動電話上的分佈見圖1所示。

圖1

1. 輸入碼鍵

· 縱橫輸入法的輸入碼碼元爲{0，1，2，3，4，5，6，7，8，9}，與移動電話的按鍵具有天然的對應關係。

2. 字結束鍵

· 按照縱橫碼的編碼規則，單字的縱橫碼最長爲4碼，最短爲1碼。

· 輸入縱橫碼，系統將顯示編碼對應的單字，按「*」字結束鍵後，系統將在單字左上方顯示序號，可按序號選擇單字。

3. 輸入法切換鍵

· 「*」鍵可用於切換縱橫輸入法、英文以及其他輸入法。

4. 詞結束鍵

· 詞組的縱橫碼最長爲6碼，最短爲1碼（簡碼）。

· 輸入縱橫碼，系統將顯示編碼對應的單字，按「#」詞切換鍵後，系統將顯示該編碼對應的詞組，並且在詞組左上方顯示序號，可按序號選擇詞組。

5. 標點符號鍵

· 在沒有輸入縱橫碼時，移動電話上的「#」鍵是常用標點符號輸入鍵。按下「#」，即可顯示常用標點符號。

6. 刪除鍵

· 可刪除當前輸入錯誤的編碼或字、標點符號。

7. 選擇鍵

· [左]/[右]選擇鍵：用來選擇字、詞組或標點符號。輸入編碼後，系統將顯示編碼對應的單字/詞組，可用[左]方向鍵向前選字、詞，用[右]方向鍵向後選字、詞。

· 顯示標點符號時，可用於選擇標點符號。

· 輸入編碼後再按下字/詞結束鍵後，可根據顯示的序號，按下“0”-“9”十個數位鍵輸入字詞。

8. 翻頁鍵

· [上]/[下]翻頁鍵：用於向前、向後翻頁。輸入編碼後，系統將顯示編碼對應的單字/詞組，可用[上]方向鍵向前翻頁，用[下]方向鍵向後翻頁。

· 顯示標點符號時，可用于標點符號的向前、向後翻頁。

9. 確定鍵

· 使用選擇鍵選擇需要輸入的字、詞或標點符號後，按確定鍵，可將選中的內容輸出。


標點符號輸入

在無編碼輸入情況下，按下「#」鍵，即可顯示常用標點符號。

圖1

按[左]/[右]選擇鍵選擇標點符號，如沒有需要的標點可按[上]/[下]翻頁鍵。

圖2

使用選擇鍵選擇需要輸入的字、詞或標點符號後，按確定鍵或按相應的序號可將選中的標點符號輸出。標點符號如下圖3所示。

注：因移動電話型號、螢幕大小不同，標點符號顯示的個數可能與例圖中顯示的不一致。

圖3


單字輸入

注：因移動電話型號、螢幕大小的不同，字詞顯示的個數可能與例圖中的顯示不一致。

（1）切換至縱橫輸入法，按移動電話的數位鍵“0”後，在移動電話螢幕下方會出現9個候選字，如下圖1。

圖1. 縱橫輸入單字

（2）若移動電話螢幕下方的候選字中出現所要輸入的漢字，按[字結束鍵]，如下圖2所示。在候選字左上方顯示數位序號，如下圖3所示。

（3）直接按候選單字相應數位序號，即可將漢字輸出到文本游標處，如下圖4所示。或使用[左]/[右]選擇鍵對該頁字進行選擇，選定所要輸入的漢字後，再按下[確定鍵]，也可將漢字輸出，如下圖5所示。 若移動電話螢幕下方的候選單字中未出現所要輸入的漢字，可按[上]/[下]翻頁鍵進行前後翻頁查找。

注：當前選中的字以紅色顯示。

（4）輸出單字後，移動電話螢幕的下方即會顯示該單字的聯想字，如上圖4所示。聯想字可按[左]/[右]選擇鍵選定，再按下[確定鍵]可輸出單字；或者按[字結束鍵]，直接輸入候選字的數位序號，輸出單字。若沒有想要輸出的字，可以使用翻頁鍵繼續查找或重新輸入數位即可，如下圖6所示。

圖6. 單字輸入後自動聯想詞


詞組輸入

注：因移動電話型號、螢幕大小的不同，字詞顯示的個數可能與例圖中的顯示不一致。

（1）輸入“歡迎”的編碼“402373”，在移動電話螢幕下方即出現“歡迎”等詞，編碼輸入至六位，候選字左上方自動顯示序號，如下圖1所示。

圖1. 縱橫詞組輸入候選列表

（2）使用[左]/[右]選擇鍵選定需要的詞再按[確定鍵]，或直接按候選詞左上方的數位序號，詞組可輸出到文本游標處，如下圖2所示。

注：當前選中的詞以紅色顯示。

圖2. 詞組輸入完成


混合輸入

注：因移動電話型號、螢幕大小的不同，字詞顯示的個數可能與例圖中的顯示不一致。

（1）按移動電話數位鍵“0”，再按字結束鍵，按數位鍵“2”，可輸出“你”字到文本游標處，如圖1所示。

圖1. 輸入並選擇“你”

（2）按移動電話數位鍵“05”，再按下詞結束鍵「#」，此時，在移動電話螢幕下方顯示的是詞組，如下圖2所示。

圖2.按下詞結束鍵「#」，顯示詞組

（3）第一個候選詞可直接按「確定鍵」進行輸出，如下圖3所示。其他候選詞可按「選擇鍵」選定需要的詞組，再按「確定鍵」輸出；或者按「#」詞結束鍵後，輸入數位序號輸出詞組。

圖3. 按下確定鍵

（4）輸入詞組“縱橫輸入法”。按移動電話數位鍵“28458”，即顯示需要的詞組，按「確定鍵」輸出，如下圖4所示。

圖 4. 輸入編碼、詞組“縱橫輸入法”

（5）在沒有輸入編碼的情況下，按一下移動電話鍵盤上的「#」號鍵，如下圖5所示。

圖5. 標點輸入鍵

（9）移動電話螢幕上即顯示縱橫輸入法提供的標點符號，按「選擇鍵」選定再按「確定鍵」或直接按左上方的序號，即可輸入所需的標點，如下圖6所示。

圖6. 標點選擇


漢字與英文

漢字與英文、數位混合輸入

（1）按一下[輸入法切換鍵]，即可在縱橫輸入法、英文、數位三種輸入之間快速切換，如下圖1所示。

圖1. 輸入法切換

（2）切換至縱橫輸入法狀態時，螢幕上方會顯示出“CKC”字樣。此時，按下數位鍵，螢幕下方顯示漢字，如下圖2所示。

圖2. 縱橫輸入狀態

（3）按一下[切換鍵]後，螢幕上方顯示爲“abc”字樣。此時，按下數位鍵，直接輸出英文字母，如下圖3所示。

圖3. 在縱橫輸入法中輸入英文字母

（4）按一下[切換鍵]後，螢幕上方顯示爲“123”字樣。此時，按下數位鍵，直接輸出數位，如下圖4。

圖4. 在縱橫輸入法中輸入數位


縱橫漢字編碼法簡介

對於如何將漢字輸入電腦，一向是中國大部分電腦使用者的一項課題，以致五花八門的各項中文輸入法應運而起，但能達到實用階段的，實在寥寥可數。由於尚未有真正簡單易學的中文輸入法，要學會一種中文輸入法，總要強記許多規則，令人望而生畏，普及「電腦中文化」受到了一定的阻力。

以數字編碼的「縱橫漢字編碼法」，符合了簡單易用的要求，在過去11年之間，在學校從試點，而達到了全面推廣的階段。縱橫漢字編碼法在江蘇、浙江，上海市的學校脫穎而出，從各學校老師對縱橫碼評價的多篇論文中，可以看出「縱橫碼」受廣大師生的青睞，不少老師不單只學習和應用，甚至研究縱橫碼，這除了是因為「縱橫漢字編碼法」的編碼邏輯外，更要歸功於「蘇州大學縱橫漢字信息技術研究所」對縱橫漢字系統軟件的不斷改進所致。

中文雖然是由單字所組合，但在表達上，80%到90%是由詞組構成的，因此縱橫漢字輸入法利用數字編碼的特點，對大量詞組集進行編碼，大大加快輸入的速度。


在縱橫漢字編碼方案中

基本筆形代碼

縱橫漢字編碼方案把筆形分為10類，分別用「0」到「9」這10個數字表示。筆形與數字代碼的關係可通過下列口訣記憶：

一橫二豎三點捺，叉四插五方塊六。

七角八八九是小，撇與左鈎都是零。

注意：複筆與單筆皆可的筆形，取筆劃複雜的筆形為碼，也即「取大不取小」。

另外，縱橫碼按楷體字為標準字型取碼，故這裡所舉字例都用楷體字。

表１　筆形代碼表

代碼 | 筆名 | 筆 形 | 說 明
０ | 撇及左鈎 |  | 撇、左鈎或帶撇的鈎
１ | 橫 |  | 橫畫、橫剔或斜剔
２ | 豎 |  | 直豎與斜豎
３ | 點及捺 |  | 點、捺
４ | 叉 |  | 二筆交叉不論直交與斜交
５ | 插 |  | 二橫一豎不論直交與斜交
６ | 方 |  | 口形
７ | 角及右鈎 |  | 角形、兩角相連或右鈎
８ | 八 |  | 「八」及其變形
９ | 小 |  | 「小」及其變形


縱橫漢字簡易版單字取碼規則

縱橫輸入法單字取碼規則

1. 取漢字四個角的筆形為編碼，取碼次序為：

1. 左上角為第一碼
2. 右上角為第二碼
3. 左下角為第三碼
4. 右下角為第四碼

如果一個漢字不足4碼（如右上角的筆形與左上角的筆形重複、右下角的筆形與左下角的筆形重複、左上角的筆形與左下角的筆形重複、右上角的筆形與右下角的筆形重複）則有幾碼取幾碼。

l 4碼字

8800

1611

2088

3397

4398

5707

6717

  • 3碼字

640

120

805

701

307

581

602

  • 2碼字

01

14

39

46

50

61

02

  • 1碼字

1 | 4 | 5 | 8 | 6 | 9 | 6

2. 如果漢字的左上角或右上角呈角形筆形，取較高的筆形。例如：

0524

0427

0520

7575

6430

5307

5307

3. 取筆形時一般不斷開，但從不同的角取的筆形不一樣時，該筆形便會斷開分別取碼。例如：

101

1720

4471

227

7106

7171

6240


0

單字快易碼

l 一碼快易碼

為使輸入更容易、更快捷，縱橫碼對部分常用字設計了一碼的快易碼輸入法，原則為取該字縱橫碼的第1碼。另外，為了方便輸入中文數字及其大寫數字，縱橫碼對中文數字「○」至「九」和中文大寫數字「零」至「玖」分別定義為「0」至「9」的一碼快易碼，例如：「六、陸」為「6」。

下列是選字視窗第一頁顯示的一碼單字，紅色為快易碼字，黑色為一碼字。

0 | 的我你他得很和○零便
1 | 要可而再及又已一壹了
2 | 將能約經出此以二貳些
3 | 這就對請新該還三叁為
4 | 有在好也其十去四肆如
5 | 把成事接或由換五伍中
6 | 是國因日目四口六陸曰
7 | 與學所長用月陳七柒反
8 | 會卻無等前人入八捌年
9 | 小常當黨快慢類九玖性

l 二碼快易碼

取碼原則為取該字的第1碼和第2碼。二碼的碼位共有100個，每一個碼有10個字，全部有1000個字。由於二碼字數目太多，在此不一一列出。


詞 組 編 碼 規 則

縱橫輸入法詞組編碼規則

詞組在縱橫輸入法佔很重要的位置，它提供了易學及快速的特色，給使用者極大的方便。縱橫輸入法2006軟件中內存詞組逾34萬餘條。分為二字詞組、三字詞組、四字詞組及多字詞組，每類詞組取碼最多為6碼。使用者可利用自定義功能，加入自己的詞組。

1. 二字詞組

以每個字的縱橫碼前3碼連在一起，構成 3+3 規則。如其中某字不足3碼，全取其碼而不用補上任何編碼。二字詞組碼長最長為6碼，最少為2碼。

下表列出66組常用二字詞組編碼

什麼 042303 | 建設 154376 | 成為 530340
可以 160287 | 研究 110347 | 技術 540012
以為 287340 | 已經 177219 | 中國 56
這樣 333489 | 不但 19062 | 東西 5916
起來 47849 | 經濟 219331 | 咱們 66072
我們 030072 | 能夠 202070 | 時候 640072
國家 6303 | 參加 230460 | 看見 056607
所以 700287 | 結果 24969 | 因為 6340
人民 8777 | 組織 279239 | 知道 868383
你們 002072 | 應該 303336 | 原來 71049
解決 070351 | 沒有 371420 | 那麼 175303
得到 062121 | 社會 34986 | 學習 770176
然後 033022 | 怎麼 833303 | 全國 816
他們 042072 | 辦法 334341 | 並且 8171
生活 051301 | 這些 333201 | 今天 8018
但是 06268 | 許多 386000 | 教育 480300
作用 082700 | 立刻 31328 | 缺點 857613
積極 059419 | 如果 46469 | 簡單 882665
發展 100703 | 熱烈 453123 | 常常 920920
現在 161421 | 大家 48303 | 懂得 941062
工作 11082 | 事情 50950 | 情況 950361
需要 12014 | 指導 500383 | 精神 959359

2. 三字詞組

取每一個字的第1及第2碼，2+2+2 即為三字詞組的取碼方法。如某一個字只有1碼可取時，就只取1碼而不用補上任何編碼。

你是否 006816 | 秘書長 045771 | 財政司 641817
優越性 014395 | 主席團 31306 | 腦神經 723521
使用法 057034 | 十週年 43785 | 有志氣 424389
工學院 117773 | 考察團 44396 | 青少年 529085
一定會 13886 | 檢查站 484131 | 全中國 8156
破天荒 141840 | 打印機 517742 | 尊敬的 834807
縱橫碼 284411 | 中學生 57705 | 人民幣 87798
編碼法 231134 | 捨不得 581906 | 常用字 927030
練習簿 251788 | 自主權 063144 | 尖沙咀 983967
江蘇省 314396 | 國務院 61873 | 快得多 950600

3. 四字詞組

先取第一個字的第1及第2碼，再取第二字及第三字的第1碼，最後取第四字第1及第2碼，2+1+1+2 即為四字詞組的取碼方法。如第一或第四個字只有1碼可取時，就只取1碼而不用補上任何編碼。

任何建議 000138 | 安心工作 343108 | 知識分子 863810
得心應手 063300 | 意想不到 334112 | 同舟共濟 720433
偉大貢獻 044123 | 地方政府 443130 | 隨心所欲 743780
北京大學 103477 | 求同存異 437468 | 有求必應 424330
天下太平 181414 | 十分重視 48036 | 分期付款 804040
一學就會 17386 | 事態嚴重 502601 | 全面推廣 811530
總工程師 261001 | 技術研究 540134 | 短期培訓 814432
出神入化 223804 | 中文信息 53006 | 光臨指導 907538
以防萬一 28741 | 首屈一指 867150 | 快快樂樂 959222
深明大義 306480 | 團結一致 62118 | 精益求精 958495

4. 多字詞組

五字或五字以上詞組，都只是對前五個字取碼，第一個字取第1及第2碼，後四個字均取縱橫碼的第1碼，2+1+1+1+1 即為五字或五字以上詞組的取碼方法。如第一個字只有1碼可取時，就只取一碼而不用補上任何編碼。

得到一致好評 061114 | 中外合資企業 50838
香港特別行政區 063060 | 中華人民共和國 54874
一而再再而三 11111 | 國際先進水平 67031
要小心處理 149321 | 只要你努力 681044
縱橫漢字編碼法 284332 | 有一利必有一弊 421034
以天下為己任 281101 | 股份有限公司 770478
祝你一路順風 360160 | 致以崇高的敬意 182230
對社會作出貢獻 343802 | 人民大會堂 87489
熱烈的歡迎 451043 | 常務副校長 921147
大家都高興 483437 | 少數民族地區 905734


0 香港

詞組快易碼

為使輸入詞組更快捷，故採取快易碼概念，將大約1000組常用詞組（以二字詞組為主）定下快易碼，使用者只需使用1碼或2碼，即可輸入常用詞。詞組以一碼為快易碼的，即以該詞組的縱橫碼第1碼為快易碼取碼。其他以二碼為快易碼的，即取該詞組的首2碼。

l 一碼快易碼

下列是選字視窗第一頁顯示的一碼快易碼詞組，每一個數碼為10個詞組，全部為100個。

0 | 香港 我們 你們 他們 代表 委員會 行政長官 香港政府 香港特區 香港特別行政區
1 | 可以 可能 已經 現在 需要 一切 一個 一定 工作 政府
2 | 經濟 以為 能夠 經過 參加 結果 繼續 將會 統計 上海
3 | 沒有 這樣 應該 方法 社會 對於 辦法 這些 許多 新的
4 | 教育 如果 大家 希望 世界 其他 根據 才能 熱烈 九龍
5 | 中國 中心 中學 中華 中文 事情 或者 中央 中國人 中華人民共和國
6 | 國家 因為 國內 國際 影響 因此 國務院 雖然 國家主席 國務院總理
7 | 學習 學校 學生 所有 所以 朋友 屬於 反對 開始 原因
8 | 人民 人們 全國 公司 全港 分別 公眾 全面 公共 全部
9 | 常常 常識 情況 常務 情形 少數 常見 掌握 小學 小學生

l 二碼快易

取碼原則為該詞組的第1碼和第2碼。二碼的碼位共有100個，每一個碼為10個詞組，全部為約1000個詞組。由於二碼詞組數目太多，在此不一一列出。